Power Failure at Plant

Incident Report for OrlandoCleaners

Resolved

This incident has been resolved.
Posted Feb 27, 2026 - 10:41 EST

Update

We are continuing to monitor for any further issues.
Posted Feb 27, 2026 - 08:48 EST

Monitoring

Power is restored. Checking key systems
Posted Feb 27, 2026 - 08:41 EST

Investigating

There is a power outage at the plant. This affects cleaning, finishing, packaging, offices, customer care, CMI, phones, and store 8.
Posted Feb 27, 2026 - 07:28 EST
This incident affected: Orlando Cleaners Services (Internet and Phone System, Servers, Plant Assembly Conveyor and Bagger) and Traditional Retail Locations (Store 8 (OBT)).