Store 33 replace photocell. Pickup kiosk down.

Incident Report for OrlandoCleaners

Resolved

Maintenance complete no customer's impacted
Posted Feb 23, 2026 - 16:14 EST

Identified

Currently replacing the photocell on the store's storage conveyor. Downtime expected to be about fifteen minutes.
Posted Feb 23, 2026 - 15:44 EST
This incident affected: Orlando Cleaners 24/7 Locations (Store 33 (Celebration) Kiosks).