Store 38 Power Disruption - *KIOSK DOWN*

Incident Report for OrlandoCleaners

Resolved

This incident has been resolved.
Posted Nov 06, 2025 - 09:35 EST

Investigating

Power at store 38 has been disrupted. The kiosk and all stations are down. We'll monitor for power restoration and reset the kiosk and conveyor as soon as possible.
Posted Nov 06, 2025 - 07:15 EST
This incident affected: Traditional Retail Locations (Store 38 (Apopka)).