Internet Connectivity issues at store 33 - partial outage

Incident Report for OrlandoCleaners

Identified

There continues to be network issues impacting this location. The pickup kiosk is running off a cellular hotspot. We continue to follow up with the ISP for prompt resolution.
Posted Jun 04, 2026 - 10:00 EDT

Monitoring

A fix has apparently been implemented and we are monitoring for resolution and perform testing to verify.
Posted Jun 04, 2026 - 06:05 EDT

Identified

Kiosks DOWN — Celebration #33

The kiosks at Store 33 (Celebration) are currently down due to a connectivity issue affecting communication with the Metalprogetti kiosk service.

The location’s internet connection is not fully offline. We can still remotely access the machines, but the kiosks cannot reliably complete outbound connections to required cloud services. TeamViewer is also showing “LAN Access Only,” which supports that this is broader than the kiosk application itself.

This issue appears isolated to this location and its ISP connection. Other Orlando Cleaners locations are not affected, and Metalprogetti has confirmed they are not seeing a broader outage.

We have escalated the issue to the ISP with documented test results.

Impact: Customer kiosk transactions are unavailable at this location.

Status: Escalated to ISP for network engineering review.
Posted Jun 03, 2026 - 11:30 EDT
This incident affects: Orlando Cleaners 24/7 Locations (Store 33 (Celebration) Kiosks).