SPOT Hosted Database Degradation

Incident Report for OrlandoCleaners

Resolved

Dear Spot Customer,

Earlier today, we experienced a technical disruption that temporarily impacted access to our services. Our team has identified the issue and implemented a fix to restore full functionality. We're pleased to confirm that the issue has now been fully resolved.

We sincerely apologize for any inconvenience this may have caused. Ensuring the reliability of our services is our top priority, and we're taking steps to review the incident thoroughly to prevent similar issues in the future.

Thank you for your patience and continued trust in Spot. If you have any concerns or are still experiencing difficulties, please reach out to our support team at 801-208-2210.

For the latest information and real-time updates, please subscribe to our status page at status.spotpos.com

Sincerely,
The Xplor Spot Team
Posted Nov 06, 2025 - 12:06 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 06, 2025 - 11:39 EST

Investigating

Spot reports the following:

We are currently investigating service degradation related to our hosted environment database servers.

Monitoring the scope and impact of the event.
Posted Nov 06, 2025 - 06:33 EST
This incident affected: Third Party Services (Xplor SPOT).